Re: [meta-fsl-arm] i.MX6 audio performance


Gary Thomas <samoht.yrag@...>
 

On 2014-01-05 10:52, Marco wrote:
Il 05/01/2014 16:16, Gary Thomas ha scritto:
On 2014-01-04 08:43, Eric Nelson wrote:
Hi Gary,

On 01/03/2014 02:05 PM, Gary Thomas wrote:
On 2014-01-03 12:24, Eric Nelson wrote:
Hi Gary,

On 01/03/2014 10:15 AM, Gary Thomas wrote:
On 2014-01-03 10:06, Eric Nelson wrote:
Hi Gary,

<snip>

I also noticed that on the SabreLite, mplayer is using an additional
library
libXxf86dga.so.1
and that it was built using hard floating point (the OMAP3 is soft).

Any ideas?
Are you forcing ALSA output using '-ao alsa'? I've seen some issues
with
OSS emulation and I'm not sure of the default.

Please advise,
No, I'm using it straight
# mplayer FILE.mp3
Same on both platforms
Do you see an output line indicating the AO used?

It should show something like this:
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)

Can you try using '-ao alsa'?
Same results. Here's everything printed by mplayer:

root@sabrelite:~# mplayer test.mp3 -ao alsa
MPlayer2 2.0-379-ge3f5043 (C) 2000-2011 MPlayer Team
162 audio & 361 video codecs

Playing test.mp3.
Detected file format: MPEG audio layer 2/3 (libavformat)
[mp3 @ 0x2bb83690]max_analyze_duration reached
[lavf] stream 0: audio (mp3), -aid 0
Clip info:
title: Wedding Bells
artist: Gas House Gang
album: Face The Music
TYER: 0
genre: Vocal
track: 2
Load subtitles in .
==========================================================================

Forced audio codec: mad
Requested audio codec family [mad] (afm=libmad) not available.
Enable it at compilation.
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, floatle, 128.0 kbit/4.54% (ratio: 16002->352800)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3
audio)
==========================================================================
This is likely the culprit. I don't think that floatle is a valid audio
format for either the SGTL5000 or HDMI devices:
It makes sound - just choppy (not like it makes only noise)

Give a listen to these to hear what I'm talking about.
http://www.mlbassoc.com/poky/sample-BAD.m4a
http://www.mlbassoc.com/poky/sample-OK.m4a


AO: [alsa] 44100Hz 2ch floatle (4 bytes per sample)
Video: no video
Starting playback...

To see if this is user code or kernel driver, I tried running my OMAP3
file system on the SabreLite (the OMAP3/Cortex-A8 is pretty much a
subset
of the CPU). Same results - broken sound when using mplayer :-(

I tested it with Gstreamer and it worked with a charm

gst-launch filesrc location=/home/root/blurred_lines.mp3 ! mpegaudioparse ! beepdec ! audioconvert ! alsasink

Just my 2 cents.
Agreed, it works fine with gstreamer, just not mplayer which works
great on all of my other platforms :-(

Join meta-freescale@lists.yoctoproject.org to automatically receive all group messages.