Re: Safe to upgrade to a Community BSP?


Val Kondratenko
 

Is there any need to update to a newer meta-freescale version with upgrade from 5.4 to 5.12 kernel.

 

Thanks,

Val

 

From: Val Kondratenko
Sent: Thursday, June 10, 2021 8:34 AM
To: meta-freescale@...
Subject: Safe to upgrade to a Community BSP?

 

 

I recently got tasked with upgrading linux kernel (which we get from freescale), to fix some vulnerabilities.

I am new to this, with all engineers with previous experience in this area no longer with company.

To fix the vulnerabilities, will need to upgrade to kernel rev 5.12.

Noticed that only a community branch of this (5.12.x+fslc) is available.   Latest freescale (imx) releases/branches are still at 5.4.

I do so, my organization has previously used on freescale/imx releases.

Is it generally safe to use the community releases?  Have their problems with bugs/instabilities with them?

 

Thanks in advance,

Val

Join meta-freescale@lists.yoctoproject.org to automatically receive all group messages.