Re: mesa no longer supports swrast starting with version 21


Tom Hochstein
 

-----Original Message-----
From: meta-freescale@lists.yoctoproject.org <meta-freescale@lists.yoctoproject.org> On Behalf Of Carlos Rafael Giani via lists.yoctoproject.org

Did anybody already look into this? According to the article, swrast was replaced
with llvmpipe. It is not clear to me why swrast was ever used,
however:

    # For parts with GPU and DRM, use osmesa, dri, and swrast
    PACKAGECONFIG_REMOVE_NXPBSP_imxgpu_imxdrm = "gallium"
    PACKAGECONFIG_APPEND_NXPBSP_imxgpu_imxdrm = "osmesa"
    DRIDRIVERS_NXPBSP_imxgpu_imxdrm           = "swrast"

Why did this need swrast for using DRM?
It seems these changes originated here [1] to fix a build issue. See [2].

[1] https://github.com/Freescale/meta-freescale/commit/3b0fc734634f8f0db1f48fc13c64cacd3d99dd92
[2] https://github.com/Freescale/meta-freescale/issues/699

Join meta-freescale@lists.yoctoproject.org to automatically receive all group messages.