Re: Kernel panic - not syncing: Requested init /linuxrc failed (error -2)

Bas Mevissen

On 20/03/2018 10:20, vlad zouth wrote:
I build an embedded linux with YOCTO for the KARO TX6S-8035 target. I use the fsl yocto project <> given by KARO.
I use the Mfgtools-TX6-2018-01 tool to flash images into the board but when i boot the device i have the following error:
*Kernel panic - not syncing: Requested init /linuxrc failed (error -2)*.
How can i fix this?
Here is the result of printenv from U-BOOT: printenv <>
This shows the Karo u-boot is configured to start /linuxrc:

default_bootargs=setenv bootargs init=/linuxrc console=ttymxc0,115200 ro debug panic=1 ${append_bootargs}

Solution 1 is to create a file fixboot.env in the /mfgtool/Profiles/TX6/custom directory containing a single line:

default_bootargs=setenv bootargs init=/<real_name_of_init> console=ttymxc0,115200 ro debug panic=1 ${append_bootargs}

with <real_name_of_init> replaced by your actual init (e.g. /sbin/init).

In the Mfgtools setup MfgToolSetup.bat you need to select this .env file when asked for additional environment settings that are found in the custom folder.

Solution 2 is to create a small executable script called /linuxrc in your rootfs with the following contents:


echo "Executing /sbin/init $@"
exec /sbin/init "$@"

This worked fine when I worked with Karo modules using a Ubuntu rootfs. Obviously, this assumes that /sbin/init is your real init.



Join to automatically receive all group messages.