Re: [meta-fsl-arm-extra] nitrogen6x: ov5642 support in master/jethro broken


Gary Thomas <samoht.yrag@...>
 

On 2015-11-10 18:56, Ian Coolidge wrote:
Carlos,

To follow up, I tested both the 3.14.28 image on jethro and the old 3.10.53 fido image in the blogpost I mentioned and both worked. Granted it took me two tries to get the ribbon
cable seated properly, maybe you're having the same issues?

You should see "camera ov5640 is found" in dmesg if it properly detects the hardware. Then you can run this gst command to show it on the screen "gst-launch-1.0 imxv4l2videosrc
device=/dev/video0 ! autovideosink".
I just verified this on my SabreLite which has OV5642 & OV5640_MIPI installed.
With the 3.10.53 kernel built in July, both sensors are found and function.
With the 3.14.28 kernel built today, only the OV5640_MIPI is found.


Thanks!
-Ian Coolidge

On Tue, Nov 10, 2015 at 3:25 PM, Ian Coolidge <ian@... <mailto:ian@...>> wrote:

Hello Carlos,

What kernel are you running? If it's the new 3.14.28 kernel you'll need to upgrade your u-boot version to our 2015.07 u-boot. I've written a blogpost about it here:
https://boundarydevices.com/compiling-latest-u-boot-for-i-mx6-2015-edition/.

If you want to keep your old u-boot version, or want an image that works for the old u-boot, we have images on this blogpost that will work and have been tested against that
hardware: https://boundarydevices.com/fido-release-of-yocto/

Thanks,
-Ian Coolidge

On Mon, Nov 9, 2015 at 2:29 PM, Otavio Salvador <otavio.salvador@... <mailto:otavio.salvador@...>> wrote:

Hello Carlos,

On Mon, Nov 9, 2015 at 7:25 PM, Carlos Rafael Giani
<dv@... <mailto:dv@...>> wrote:
> I tried to use the nitrogen6x' camera, and saw that no ov5642 hardware was
> detected. The kernel module was loaded.
> With the fido kernel and the exact same hardware, it works just fine.
> Is this a known issue?

Added Boundary's fellows on Cc.

--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9981-7854 <tel:%2B55%20%2853%29%209981-7854> Mobile: +1 (347) 903-9750 <tel:%2B1%20%28347%29%20903-9750>




Join meta-freescale@lists.yoctoproject.org to automatically receive all group messages.