Re: gstreamer1.0 element conflicts


Tim Harvey
 

On Wed, Apr 8, 2015 at 12:40 PM, Carlos Rafael Giani
<dv@...> wrote:
I don't think so. I however can rename the gstreamer-imx one to
imxv4l2videosrc . Is this acceptable?
Carlos,

I think this would be a fine approach - it would also help differ
gstreamer-imx from the other closed-development plugins.

Tim


Am 2015-04-08 um 21:01 schrieb Pushpal Sidhu:

Hi all,

There is conflict in imxv4l2src as it's provided both by gstreamer-imx
and gst1.0-fsl-plugins. I renamed the element in gst1.0-fsl-plugins,
but gstreamer complains that: "(gst-plugin-scanner:652):
GLib-GObject-WARNING **: cannot register existing type
'GstImxV4l2Src'"

I am currently using the master branch in meta-fsl-arm. Ideally, I
would like to keep both elements with a rename on the
gst1.0-fsl-plugins variety. Is there any (simple) method of
accomplishing this?

Thanks,
- Pushpal

Join meta-freescale@lists.yoctoproject.org to automatically receive all group messages.